Splack Linux
Slackware for Sparc
Login Welcome to Splack Linux
Friday, January 19 2018 @ 09:41 AM

 Forum Index > General > General discussion
 Keyboard problem in GUI
 |  Printable Version
By: Anonymous: philo_565 () on Tuesday, September 02 2008 @ 12:49 PM (Read 35646 times)  
Anonymous: philo_565

Although Ihave installed Slackware many times on i386 systems..
I recently got my first SPARC machine a few weeks ago...and old Sun Workstation 5 vintage 1994.

Although I had no problems installing SPLACK, I am having a big problem setting up the x-server.

Though xorg properly ID'ed the Sun video card, I absolutely could not get the sun mouse
working...so as a workaround installed a serial mouse. Finally able to boot to the GUI...
but the keyboard mapping is all wrong. I am in the US and if I use "us" or "en_US"...the
mapping is 100% incorrect.

If I use no mapping at all, the top two rows of keys are OK...
but the entire lower row of keys has no function at all...
and most of the keys one row up fromt he bottom work...but not all!

For the time being I have had to give up...
but since I have a number of spare drives have managed to get Debian, Net BSD
and Solaris 8 all working with no problems

Thanks





       
   
By: manolo (offline) on Tuesday, September 02 2008 @ 02:46 PM  
manolo

HI
I install this distro in a sparc 60 whith a sun "us" original keyboard , and all is ok but not the keyboard in X windows.
I also have the same problem , with the mouse , but editing the xorg.conf in the section mouse, i finally have the mouse , that is connected to keyboard working in GUI.
please try this:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "busmouse"
Option "Device" "/dev/sunmouse"
EndSection

In my ultra 60 I,m not able to have the keyboard working...........properly
I hope that helps
manuel


Forum Newbie
Newbie

Status: offline

Registered: 08/28/08
Posts: 1

Profile Email    
   
By: crn (offline) on Tuesday, September 02 2008 @ 03:49 PM  
crn

I have mentioned this on the IRC channel in where the developers hang out but no response so far. I have no way of testing X here but I have a suspicion that this may be a version issue. The 2.6 kernel translates all keys to X86 layout so we have to use the X86 mappings (when not using X) for international layouts.

Try using the default X86 keyboard setings in xorg.conf.


Forum Admin
Admin

Status: offline

Registered: 09/17/04
Posts: 8

Profile Email    
   
By: Anonymous: philo_565 () on Tuesday, September 02 2008 @ 07:15 PM  
Anonymous: philo_565

Quote by: manolo

HI
I install this distro in a sparc 60 whith a sun "us" original keyboard , and all is ok but not the keyboard in X windows.
I also have the same problem , with the mouse , but editing the xorg.conf in the section mouse, i finally have the mouse , that is connected to keyboard working in GUI.
please try this:

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "busmouse"
Option "Device" "/dev/sunmouse"
EndSection

In my ultra 60 I,m not able to have the keyboard working...........properly
I hope that helps
manuel



Yes I had tried /dev/sunmouse

but the machine locked up in the GUI mode...

but the serial mouse is fine...

thanks for the reply





       
   
By: Anonymous: philo_565 () on Tuesday, September 02 2008 @ 09:35 PM  
Anonymous: philo_565

Quote by: crn

I have mentioned this on the IRC channel in where the developers hang out but no response so far. I have no way of testing X here but I have a suspicion that this may be a version issue. The 2.6 kernel translates all keys to X86 layout so we have to use the X86 mappings (when not using X) for international layouts.

Try using the default X86 keyboard setings in xorg.conf.




CLI all is fine

in GUI keyboard map is all wrong no matter which layout I use...
I tried them all.
If i use NO layout at all,
then at least some of the keys work...
but no matter what, the bottom row of keys has no function at all





       
   
By: Anonymous: crn () on Wednesday, September 03 2008 @ 04:18 PM  
Anonymous: crn

Try this xorg.conf which was contributed by another user.

ftp://ftp.splack.org/pub/splack/people/ ... conf-sunfb





       
   
By: Anonymous: philo_565 () on Wednesday, September 03 2008 @ 09:12 PM  
Anonymous: philo_565

Quote by: crn

Try this xorg.conf which was contributed by another user.

ftp://ftp.splack.org/pub/splack/people/ ... conf-sunfb



I assure you I tried that and it does not work...
I have tried virtually every kbd configuration imaginable...
and thus far the best results are those with NO
keyboard configuration specified...
but even that is only partially working

thanks for the reply





       
   
By: crn (offline) on Wednesday, September 03 2008 @ 11:48 PM  
crn

I have just had a long chat with the developers on IRC and they are aware of the problem.
Basically X is an old version which is not compatible with the kernel, A fix is on the to-do list.

Please be patient.


Forum Admin
Admin

Status: offline

Registered: 09/17/04
Posts: 8

Profile Email    
   
By: Anonymous: philo_565 () on Thursday, September 04 2008 @ 03:03 AM  
Anonymous: philo_565

Quote by: crn

I have just had a long chat with the developers on IRC and they are aware of the problem.
Basically X is an old version which is not compatible with the kernel, A fix is on the to-do list.

Please be patient.



Thank you for the reply...
and I am relieved to know the problem is not on my end...
In all the years I've been setting up x-servers I've never previously
had to even think about the keyboard.

I'





       
   



 All times are GMT. The time is now 09:41 AM.
Normal Topic Normal Topic
Locked Topic Locked Topic
Sticky Topic Sticky Topic
New Post New Post
Sticky Topic W/ New Post Sticky Topic W/ New Post
Locked Topic W/ New Post Locked Topic W/ New Post
View Anonymous Posts 
Able to Post 
HTML Allowed 
Censored Content